Slow e-mail on forum fixed

Slow e-mail on forum fixed

By | 2016-12-01T16:37:49+00:00 December 12th, 2011|Uncategorized|3 Comments

For the last couple of months, e-mails sent from the forum have taken many hours to arrive. This was particularly frustrating to new users who want to ask a question and have to wait until the next day for their verification e-mail to arrive, but it also delayed my ability to get notified that a new post needed attention.

Last week I was able to dig into this. Initially I suspected the web hosting company had an overloaded e-mail server, so I submitted a help desk ticket with them. They couldn’t find any issues on their end, so I started looking at the source code of the open source forum software YetAnotherForum.NET. Eventually I tracked down an issue with their code, which I was able to work around by clearing out one of the database tables that held e-mails waiting to get sent. I submitted an issue with their bug tracker, so hopefully they’ll be able to resolve it.

E-mails seem to be instantaneous again, so I think we are back in business. I offer my apologies for any inconvenience this has caused.

About the Author:

Founder and Lead Developer of Gallery Server

3 Comments

  1. Dave Burke January 13, 2012 at 6:56 am

    Hi Roger, Thanks for posting about this. YAF has a long history of email sensitivities.

    I thought I’d mention that your GSP Forum RSS Feed links don’t seem to work when attempting to subscribe in Google Reader or other readers. (It doesn’t work for Thunderbird either, which is what I use for RSS.)

    I did some research on YAF Forums on this and there are RSS Permission settings on Host Settings –> Features. Access needs to be set to “All Users.”

    I’d really like to stay current on GSP Forums via RSS. I’ve been slacking off in that department. Could you please take a quick look-see at the YAF RSS permissions and see if that’s the issue?

    Thanks so much!
    -Dave

  2. Roger Martin January 13, 2012 at 7:30 am

    Indeed, the settings were set to registered users. I changed it to all users. Try it now.

    Thanks for letting me know, and an extra big thanks for offering the solution.

  3. Dave Burke January 13, 2012 at 2:52 pm

    Works beautifully! Thank you for your speedy responsiveness, as always. No need to thank me though. My motivations were purely selfish. 🙂

    btw, I’m Day 2 on GSP 2.6 at Sueetie.com. Once again, the app seems even faster than the previous release. I like the changes in the File Upload behind-the-scenes code, too. Much cleaner. No more “AddUploadControlForLessThanFullTrust()” for starters.

    Keep up the great work.
    -Dave

Leave A Comment